Mac で mysql-simple を cabal install するときにハマった

2015/06/05

依存ライブラリである pcre-light のインストール時にpcre.hが無いと怒られる

https://github.com/bos/mysql-simple/issues/15

対処法

まずはpcre.hをいれる

brew install pcre

次にcabalにpcreが入ってる場所を指定して cabal install する

$ cabal install mysql-simple --extra-include-dirs=/usr/local/include/

これで正常に入った

このエントリーをはてなブックマークに追加